当前位置:首页 > 程序设计 > 易语言程序设计 > 游戏辅助 > 详细内容
SPY++ 结合易语言简单应用02010107-01源码
作者:潇潇  发布时间:2009-12-5  阅读次数:3918  字体大小: 【】 【】【

教学课题:SPY++ 结合易语言简单应用之获取目标窗口句柄
教学要点:易语言编程坏境,以计算器为例模拟鼠标输入QQ号:854487915
教学步骤:1、认识API函数:FindWindow
FindWindow查找窗口),返回窗口句柄,类型:整数型;参数一:目标窗口类名,类型:文本型;参数二:目标窗口标题(或名称),类型:文本型
Declare Function FindWindow Lib "user32" Alias "FindWindowA" (ByVal lpClassName As String, ByVal lpWindowName As String) As Long

               2、利用API函数FindWindow,获取“计算器”的窗口句柄

窗口程序集1:

.版本 2

.程序集 窗口程序集1

.子程序 _按钮1_被单击
.局部变量 窗口句柄, 整数型

窗口句柄查找窗口_ (“SciCalc”, “计算器”)
编辑框1.内容 = 到文本 (窗口句柄)


DLL命令定义表:

.版本 2

.DLL命令 查找窗口_, 整数型, "user32", "FindWindowA"
    .参数 窗口类名, 文本型
    .参数 窗口标题, 文本型

来源:潇潇的编程网站
我要评论
  • 匿名发表
  • [添加到收藏夹]
  • 发表评论:(匿名发表无需登录,已登录用户可直接发表。) 登录状态:未登录
最新评论
所有评论[1]
    暂无已审核评论!
Web Lite SWeTE: Simple Website Translation Engine
 


设为首页 | 加入收藏 | 意见建议 | 友情链接 | 版权声明 | 管理登陆 | 编程论坛 | 给我留言

声明:本网站部分稿件来源的所有文字、图片和音视频稿件,来自互联网,若侵犯您的权利,请来信告知,我们将在第一时间内删除!


Copyright 2009-2015 redrose ( wgbcw.cn ) All rights reserved ICP备案编号:滇ICP备09007156号 Dict.cn


点击这里给我发消息
点击这里给我发消息
安全联盟站长平台