当前位置:首页 > 程序设计 > 易语言程序设计 > 游戏辅助 > 详细内容
SPY++ 结合易语言简单应用02010107-02源码
作者:潇潇  发布时间:2009-12-5  阅读次数:3513  字体大小: 【】 【】【

教学课题:SPY++ 结合易语言简单应用之取目标窗口矩形坐标及设置鼠标指针
教学要点:易语言编程坏境,以计算器为例模拟鼠标输入QQ号:854487915
教学步骤:1、认识API函数:SetCursorPosGetWindowRect,坐标结构(数据类型)RECT
SetCursorPos(设置鼠标指针),成功为非零,失败为零,返回类型:整数型。参数一:目标坐标X,类型:整数型;参数二:目标坐标Y,类型:整数型。
Declare Function SetCursorPos Lib "user32" Alias "SetCursorPos" (ByVal x As Long, ByVal y As Long) As Long

GetWindowRect(取目标窗口矩形坐标),成功为非零,失败为零,返回类型:整数型。参数一:目标窗口句柄,类型:整数型,参数二:矩形坐标结构,类型RECT矩形坐标结构
Declare Function GetWindowRect Lib "user32" Alias "GetWindowRect" (ByVal hwnd As Long, lpRect As RECT) As Long

Type RECT
Left As Long '屏幕到目标窗口的左边距
Top As Long '屏幕到目标窗口的顶边距
Right As Long '屏幕到目标窗口的右边距
Bottom As Long '屏幕到目标窗口的底边距
End Type

窗口程序集1代码:

.版本 2

.程序集 窗口程序集1

.子程序 _按钮1_被单击
.局部变量 窗口坐标结构, 矩形坐标结构
.局部变量 窗口句柄, 整数型
.局部变量 x, 整数型
.局部变量 y, 整数型

窗口句柄 = 查找窗口_ (“SciCalc”, “计算器”)
编辑框1.内容 = 到文本 (窗口句柄)
.如果 (窗口句柄 ≠ 0)
       取窗口矩形坐标 (窗口句柄, 窗口坐标结构)
       置鼠标坐标 (350, 170)


DLL命令定义表代码:

.版本 2

.DLL命令 查找窗口_, 整数型, "user32", "FindWindowA"
       .参数 窗口类名, 文本型
       .参数 窗口标题, 文本型

.DLL命令 置鼠标坐标, 整数型, "user32", "SetCursorPos"
       .参数 鼠标坐标X, 整数型
       .参数 鼠标坐标Y, 整数型

.DLL命令 取窗口矩形坐标, 整数型, "user32", "GetWindowRect"
       .参数 窗口句柄, 整数型
       .参数 坐标结构, 矩形坐标结构

自定义数据类型表:

.版本 2

.数据类型 矩形坐标结构, , RECT
       .成员 左边, 整数型
       .成员 顶边, 整数型
       .成员 右边, 整数型
       .成员 底边, 整数型

来源:潇潇的编程网站
我要评论
  • 匿名发表
  • [添加到收藏夹]
  • 发表评论:(匿名发表无需登录,已登录用户可直接发表。) 登录状态:未登录
最新评论
所有评论[0]
    暂无已审核评论!
Web Lite SWeTE: Simple Website Translation Engine
 


设为首页 | 加入收藏 | 意见建议 | 友情链接 | 版权声明 | 管理登陆 | 编程论坛 | 给我留言

声明:本网站部分稿件来源的所有文字、图片和音视频稿件,来自互联网,若侵犯您的权利,请来信告知,我们将在第一时间内删除!


Copyright 2009-2015 redrose ( wgbcw.cn ) All rights reserved ICP备案编号:滇ICP备09007156号 Dict.cn


点击这里给我发消息
点击这里给我发消息
安全联盟站长平台