当前位置:首页 > 程序设计 > 易语言程序设计 > 数据库 > 详细内容
易语言读取Mysql数据库演示源码
作者:admin  发布时间:2010-4-22  阅读次数:23372  字体大小: 【】 【】【

.版本 2
.支持库 mysql
.支持库 eGrid

.程序集 窗口程序集1
.程序集变量 记录集句柄, 整数型
.程序集变量 Mysql句柄, 整数型

.子程序 _按钮1_被单击

Mysql句柄 = 连接MySql (编辑框1.内容, 编辑框2.内容, 编辑框3.内容, 编辑框5.内容, 到整数 (编辑框4.内容))
.如果 (Mysql句柄 ≠ 0)
    显示表名 ()
    按钮2.禁止 = 假
    编辑框1.禁止 = 真
    编辑框2.禁止 = 真
    编辑框3.禁止 = 真
    编辑框4.禁止 = 真
    编辑框5.禁止 = 真
    按钮1.禁止 = 真
.否则
    信息框 (“连接数据库失败,请检查Mysql主机地址?或用户名?或密码?或端口?或数据库?是否正确”, 0, “潇潇编程提示您”)
.如果结束


.子程序 _按钮2_被单击

释放记录集 (记录集句柄)
断开MySql (Mysql句柄)
按钮2.禁止 = 真
按钮1.禁止 = 假
编辑框1.禁止 = 假
编辑框2.禁止 = 假
编辑框3.禁止 = 假
编辑框4.禁止 = 假
编辑框5.禁止 = 假


.子程序 显示表名
.局部变量 记录集行数, 整数型
.局部变量 表名称, 文本型
.局部变量 i, 整数型

列表框1.清空 ()
.如果 (选择库 (Mysql句柄, 编辑框5.内容))
    .如果 (取表名列表 (Mysql句柄))
        记录集句柄 = 取记录集 (Mysql句柄)
        记录集行数 = 取记录集行数 (记录集句柄)
        分组框1.标题 = “表名称列表(” + 到文本 (记录集行数) + “个)”
        .计次循环首 (记录集行数, i)
            .如果真 (读字段值 (记录集句柄, 0, 表名称) = 真)
                列表框1.加入项目 (表名称, )
                到下一行 (记录集句柄)
            .如果真结束

        .计次循环尾 ()
    .否则
        信息框 (“取数据表名称列表失败!”, 0, “提示”)
    .如果结束

.否则
    信息框 (“选择数据库失败,请检查所要查寻的数据库名称”, 0, “潇潇编程提示您”)
.如果结束


.子程序 取表数据
.参数 数据表名称, 文本型
.局部变量 字段总数, 整数型
.局部变量 i, 整数型
.局部变量 记录集行数, 整数型
.局部变量 列, 整数型
.局部变量 行, 整数型
.局部变量 字段名, 文本型
.局部变量 字段值, 文本型
.局部变量 句柄, 整数型

高级表格1.清空数据 ()
.如果 (执行SQL语句 (Mysql句柄, “select * from ” + 数据表名称))
    句柄 = 取记录集 (Mysql句柄)
    字段总数 = 取字段总数 (句柄)
    记录集行数 = 取记录集行数 (句柄)
    .计次循环首 (字段总数, i)
        序号到字段名 (句柄, i - 1, 字段名)
        高级表格1.插入列 (字段名, i)
    .计次循环尾 ()
    ' 输出调试文本 (到文本 (字段总数) + “:” + 到文本 (记录集行数))
    .计次循环首 (记录集行数, 行)
        .计次循环首 (字段总数, 列)
            序号到字段名 (句柄, 列 - 1, 字段名)
            读字段值 (句柄, 字段名, 字段值)
            .如果 (列 = 1)
                高级表格1.插入行 (“”, 行)
                高级表格1.置数据 (行, 列, 1, 字段值)
            .否则
                高级表格1.置数据 (行, 列, 1, 字段值)
            .如果结束

        .计次循环尾 ()
        到下一行 (句柄)
    .计次循环尾 ()
.否则
    信息框 (“执行SQL语句失败”, 0, “潇潇编程提示您”)
.如果结束


.子程序 _列表框1_列表项被选择
.局部变量 结果文本, 文本型

.如果 (查找表 (Mysql句柄, 列表框1.取项目文本 (列表框1.现行选中项)))
    取表数据 (列表框1.取项目文本 (列表框1.现行选中项))
.否则

mysql for e

来源:潇潇的编程网站 http://www.wgbcw.cn/
上一篇:易语言操作SQL Server数据库全过程 下一篇:没有了!
我要评论
  • 匿名发表
  • [添加到收藏夹]
  • 发表评论:(匿名发表无需登录,已登录用户可直接发表。) 登录状态:未登录
最新评论
所有评论[2]
  • 评论人:[匿名] 时间: [2012-6-12 10:15:39] IP:[120.15.158.8*]
  • 不明白你写的数据库的链接方法,能不能详细的给说一下,我QQ:478208924
最新发布
热门文章
Web Lite SWeTE: Simple Website Translation Engine
 


设为首页 | 加入收藏 | 意见建议 | 友情链接 | 版权声明 | 管理登陆 | 编程论坛 | 给我留言

声明:本网站部分稿件来源的所有文字、图片和音视频稿件,来自互联网,若侵犯您的权利,请来信告知,我们将在第一时间内删除!

Copyright 2009-2015 redrose ( wgbcw.cn ) All rights reserved ICP备案编号:滇ICP备09007156号 Dict.cn

点击这里给我发消息
点击这里给我发消息
安全联盟站长平台